Results 1 to 2 of 2

Thread: digi speedo

  1. #1
    Baby Twin
    Join Date
    Jul 2016
    Location
    Sleaford
    Posts
    1

    digi speedo

    both speedo and rev counter playing up any ideas or help would be grateful. Speedo just runs from 0-200 kph then 0. rev counter wont even move when bike is started and wont go above 2000 revs very annoying as had to sit behind car as there were a few cash cows on the way home from work.

  2. #2
    One Litre Duc Eater Paul D's Avatar
    Join Date
    Jan 2015
    Location
    Midlands (UK)
    Posts
    541
    Make sure white connector on back of clocks is properly connected and no loose wires. Other than that it's most likely to be the clocks going faulty internally.

    I just had to replace my clocks due to an internal fault affecting temp reading, low fuel light and voltage reading.

Similar Discussions

  1. Speedo sensor
    By reded1977 in forum Want to Buy
    Replies: 4
    Last Post: September 10th, 2012, 10:50 AM
  2. Speedo not working
    By Judge in forum Aprilia RSV Tuono
    Replies: 17
    Last Post: February 2nd, 2012, 08:18 AM
  3. speedo change to kph
    By shanksa in forum Aprilia RSV Tuono
    Replies: 9
    Last Post: June 17th, 2011, 11:57 AM
  4. speedo caple
    By steven maher in forum Aprilia RSV Tuono
    Replies: 3
    Last Post: December 10th, 2010, 06:14 AM
  5. Speedo - HELP
    By titaniumleg in forum Want to Buy
    Replies: 0
    Last Post: May 25th, 2009, 03:24 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


SEO by vBSEO 3.6.1