Results 1 to 7 of 7

Thread: Indicators flashing too fast

  1. #1
    Baby Twin
    Join Date
    Sep 2015
    Location
    Scotland
    Posts
    12

    Indicators flashing too fast

    Anyone know why my indicators are flashing too fast? Gen 1 Tuono Fighter 2003
    Got told to change the wattage of the bulbs and that would help but it stopped the indicators working altogether.
    On the front there are 10W bulbs and on the back are 21W. I tried 21W on the front and this is when they didn't work.
    There is also a horrible noise from the dashboard when I put the indicators on, is this normal?
    I'm not very good with electrics so any well will be grateful
    Cheers

  2. #2
    Superbike Twin
    Join Date
    Apr 2015
    Location
    United Kingdom
    Posts
    136
    Hey,

    FYI, it seems you have posted this is 'classifieds', you might have better luck elsewhere. I don't know that much about electrics, but I know there is an indicator relay behind the bikini fairing. If you are fiddling about removing indicators while the ignition is on this will flick on and off frantically (horrible noise). If the ignition is off I believe it should not be powered.

    Different spec indicators might need a different relay. I don't know much more than that.

    I suggest you ask again in the Tuono 1000 section. Be warned they are a grumpy bunch on here.
    Paul

  3. #3
    Baby Twin
    Join Date
    Sep 2015
    Location
    Scotland
    Posts
    12
    Thanks Paul, I'll do my best not to offend anyone.

    Sent from my SM-G935F using Tapatalk

  4. #4
    One Litre Duc Eater Paul D's Avatar
    Join Date
    Jan 2015
    Location
    Midlands (UK)
    Posts
    541
    Shelter, were only grumpy on a Monday morning, or when our T's won't start, so you should be OK most of the time!

    Double rate of flashing usually means one bulb has failed. If all your bulbs are fine maybe the relay is faulty.

  5. #5
    Baby Twin
    Join Date
    Sep 2015
    Location
    Scotland
    Posts
    12
    Quote Originally Posted by Paul D View Post
    Shelter, were only grumpy on a Monday morning, or when our T's won't start, so you should be OK most of the time!

    Double rate of flashing usually means one bulb has failed. If all your bulbs are fine maybe the relay is faulty.
    Cheers Paul,
    That is my next port of call it's become the least of my worries at the moment with my T. Changed the levers recently and now it would appear my clutch is slipping in 4th so not sure how long the clutch lever actuator pin should be, I've tried shortening it but not been out on it since.... typical Scottish Highlands weather!!!!

    Have you ever had this kind of trouble or know how long the pin should be? or is it a case of suck it and see and keep changing it to see if it helps. Maybe it's not the levers that's the problem!! slowly losing all confidence in my T something else goes wrong every time I'm out on the hoor...

    Any help is grateful Paul 👍

    Sent from my SM-G935F using Tapatalk

  6. #6
    Superbike Twin
    Join Date
    Apr 2015
    Location
    United Kingdom
    Posts
    136
    I have barely any idea about clutches and slipage- having not experienced that issue yet (until riding home after reading this, when paranoia set in- 'is it?' 'isn't it?' - thanks for the poisonous idea )

    My advice would be to start a new thread in the tuono 100o section.
    Aprilia Tuono 1000
    I did a quick search, and there are a few previous threads you could read through. Other than that I am useless to you, sorry.
    P

  7. #7
    Baby Twin
    Join Date
    Sep 2015
    Location
    Scotland
    Posts
    12
    No worries Paul cheers for your advice and sorry for the demon thoughts I'm sure there's nowt wrong with yours👍

    Shechter



    Sent from my SM-G935F using Tapatalk

Similar Discussions

  1. Starting problem EFI light flashing.
    By tezzpip in forum Aprilia RSV Tuono
    Replies: 17
    Last Post: August 16th, 2014, 11:43 AM
  2. One fast Merc
    By shotgun in forum Motorcycle Talk
    Replies: 6
    Last Post: March 26th, 2014, 12:39 PM
  3. How fast have you ridden...?
    By fighterDaz in forum Motorcycle Talk
    Replies: 42
    Last Post: February 19th, 2012, 01:27 PM
  4. Fast chick on an Aprilia!!
    By shvlheadwolf in forum Motorcycle Talk
    Replies: 5
    Last Post: March 22nd, 2011, 12:39 AM
  5. May Fast Bikes
    By DAVE B in forum Aprilia RSV Tuono
    Replies: 0
    Last Post: March 10th, 2011, 10:37 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


SEO by vBSEO 3.6.1