Results 1 to 11 of 11
Thanks Tree6Thanks
  • 1 Post By joebest987
  • 1 Post By hs2300
  • 1 Post By joebest987
  • 1 Post By joebest987
  • 1 Post By hs2300
  • 1 Post By joebest987

Thread: Dash/Clocks

  1. #1
    Baby Twin
    Join Date
    Feb 2018
    Location
    nottingham
    Posts
    9

    Dash/Clocks

    Hi Guys.

    New to the Forum and Tuono scene.

    I have just bought a stunning 2016 Tuono Factory Aprc(pictures coming soon)

    Sadly I have took it out for my first ride today and noticed the digital side of the clocks has gone out, with just the orange backlight remaining, I have started it up since and they are back on. However I have spoke to the guy who I bought it from and he says that yes it does go off at times, but itís never bothered him! It will certainly bother me!!

    Is this a known issue? Or can anyone shed any light on this?

    Thanks for any advice

    Joe

  2. #2
    Baby Twin Heppy's Avatar
    Join Date
    Nov 2012
    Location
    West Yorks
    Posts
    64
    Quote Originally Posted by joebest987 View Post
    Hi Guys.

    New to the Forum and Tuono scene.

    I have just bought a stunning 2016 Tuono Factory Aprc(pictures coming soon)

    Sadly I have took it out for my first ride today and noticed the digital side of the clocks has gone out, with just the orange backlight remaining, I have started it up since and they are back on. However I have spoke to the guy who I bought it from and he says that yes it does go off at times, but itís never bothered him! It will certainly bother me!!

    Is this a known issue? Or can anyone shed any light on this?

    Thanks for any advice

    Joe
    This happens to mine intermittently, but has always been ok after turning off then on again, so never bothered to pursue a solution. I thought it could be a boot up issue? Would be good to know if it's a fault or not.

  3. #3
    Baby Twin
    Join Date
    Feb 2018
    Location
    nottingham
    Posts
    9
    Mine have booted up okay, it seams to be when I start riding they go off, maybe a loose connection. I am tempted to see if I can do a warranty claim as it has 3 weeks left until it’s 2 years old.
    Thanks from Heppy

  4. #4
    Evil Twin hs2300's Avatar
    Join Date
    Aug 2015
    Location
    Sheffield
    Posts
    443
    I think there was a firmware update to stop this happening contact your dealer
    Thanks from Heppy

  5. #5
    Baby Twin
    Join Date
    Feb 2018
    Location
    nottingham
    Posts
    9
    Spoke to the dealers today, they have said they need to see the fault occur(this may be a problem as it’s intermittant!)
    For them to file a claim.
    The guy said it’s an issue they have not heard of...

    It has got a pending recall on something to do with a Pin on one of the Brake Calipers which will be done at the same time.
    Thanks from Heppy

  6. #6
    Baby Twin spout's Avatar
    Join Date
    Jan 2016
    Location
    midlands
    Posts
    3
    Hi Joe,
    Dash firmware update needed. Had exactly the same issue, mine fixed under warranty. Aprilia dealer only. Pick one that knows exactly what needs doing! Bikersworld in East Grinstead are very good. Bit of a trek for you though.

  7. #7
    Evil Twin hs2300's Avatar
    Join Date
    Aug 2015
    Location
    Sheffield
    Posts
    443
    Quote Originally Posted by joebest987 View Post
    Spoke to the dealers today, they have said they need to see the fault occur(this may be a problem as it’s intermittant!)
    For them to file a claim.
    The guy said it’s an issue they have not heard of...

    It has got a pending recall on something to do with a Pin on one of the Brake Calipers which will be done at the same time.
    Who is your dealer Joe?

  8. #8
    Baby Twin
    Join Date
    Feb 2018
    Location
    nottingham
    Posts
    9
    It’s Via Moto in sheffield- not used them before as Aprilia is New to me, I’ve only ever had Hondas which have always been superb. Although I have had to jump ship as they have fallen behind in the super naked league!

    I sure will mention to them about this firmware update as the guy on the phone who seamed quite knowledgable certainly had not heard of this...
    Thanks from Heppy

  9. #9
    Evil Twin hs2300's Avatar
    Join Date
    Aug 2015
    Location
    Sheffield
    Posts
    443
    Quote Originally Posted by joebest987 View Post
    It’s Via Moto in sheffield- not used them before as Aprilia is New to me, I’ve only ever had Hondas which have always been superb. Although I have had to jump ship as they have fallen behind in the super naked league!

    I sure will mention to them about this firmware update as the guy on the phone who seamed quite knowledgable certainly had not heard of this...
    They are great guys there I am sure they will get you sorted out
    Thanks from Heppy

  10. #10
    Baby Twin
    Join Date
    Feb 2018
    Location
    nottingham
    Posts
    9
    Quick update for anyone having the same issues...

    Via Moto have done the clock update, so far so good. They also did the brembo recall.

    Had a service whilst in as well. 2nd service- £220 bit more than I was expecting to be fair!! Happy none the less. Bring on the summer...
    Thanks from Heppy

  11. #11
    Evil Twin hs2300's Avatar
    Join Date
    Aug 2015
    Location
    Sheffield
    Posts
    443
    Quote Originally Posted by joebest987 View Post
    Quick update for anyone having the same issues...

    Via Moto have done the clock update, so far so good. They also did the brembo recall.

    Had a service whilst in as well. 2nd service- £220 bit more than I was expecting to be fair!! Happy none the less. Bring on the summer...
    Great result Joe

Similar Discussions

  1. BEWARE THE CLOCKS!!!! dash Install help
    By Righteousbro in forum Mechanical and Technical
    Replies: 1
    Last Post: August 23rd, 2017, 01:31 PM
  2. clocks / dash change
    By Carlmack in forum Mechanical and Technical
    Replies: 4
    Last Post: August 19th, 2016, 09:40 AM
  3. Gen 2 clocks/dash
    By davyramone in forum Want to Buy
    Replies: 0
    Last Post: February 28th, 2012, 07:37 AM
  4. dash query
    By seanramsay in forum Aprilia RSV Tuono
    Replies: 4
    Last Post: May 5th, 2009, 08:01 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


SEO by vBSEO 3.6.1