Results 1 to 12 of 12
Thanks Tree2Thanks
  • 1 Post By 4vr
  • 1 Post By snowman

Thread: 10w40 oil !!! Food for thought!

  1. #1
    Baby Twin
    Join Date
    Dec 2015
    Location
    Scotland
    Posts
    19

    10w40 oil !!! Food for thought!

    Guys you may have read some of my posts on here about the engine change I done. I genuinely think my problems started when I changed the oil to 10w40!! I had bottom end failure resulting in a very expensive new engine fix. I have spoken to a few mechanics about it and they agree. I ride bikes hard as I'm sure many of you do.
    I looked on here and seen lots of people were using 10w40 so I thought that will do me as 15w50 is expensive, 50. How wrong was I!! I was fuckin mad with myself for scrimping on something like this but what's done is done.

    Take what you want from this but if it says 15w50 in the book it's probably for a reason. People say that it's for hotter climates and stuff but I say bollox. Use 15w50 lads

  2. #2
    One Litre Duc Eater
    Join Date
    Mar 2012
    Location
    southampton area
    Posts
    936
    15/50 semi always in mine from new 09 V2

  3. #3
    AMA Pit Boss
    Join Date
    Feb 2015
    Location
    Oxfordshire
    Posts
    3,973
    10/40 wouldn't cause that to happen it would have happened anyway

  4. #4
    4vr
    4vr is offline
    Evil Twin 4vr's Avatar
    Join Date
    Aug 2014
    Location
    manchester
    Posts
    265
    agreed, 75k on mine only ever used 10/40, sold on and still doing the rounds!
    Thanks from Blade

  5. #5
    Baby Twin Shrike's Avatar
    Join Date
    Dec 2015
    Location
    UK
    Posts
    28
    Mine has 10/40 but im changing to 15/50 next service

  6. #6
    One Litre Duc Eater
    Join Date
    Mar 2012
    Location
    southampton area
    Posts
    936
    Mine on Putoline 15/50 semi, from JC , Rally ?? On web approx 38 next day post , I always phone the order through ?

  7. #7
    One Litre Duc Eater Paul D's Avatar
    Join Date
    Jan 2015
    Location
    Midlands (UK)
    Posts
    541
    Quote Originally Posted by snowman View Post
    Mine on Putoline 15/50 semi, from JC , Rally ?? On web approx 38 next day post , I always phone the order through ?
    Same here. But I agree with Blade, 10W40 wouldn't cause that to happen, which normally suits the UK temps v-well. The oil quality API rating is a different matter though.

  8. #8
    One Litre Duc Eater
    Join Date
    Mar 2012
    Location
    southampton area
    Posts
    936
    Agree with the engine failure not down to oil ,.
    Thanks from Blade

  9. #9
    Baby Twin
    Join Date
    Dec 2015
    Location
    Scotland
    Posts
    19
    Just wanted to let others know of my problem. Wouldn't want it to happen to anybody else

  10. #10
    Evil Twin hs2300's Avatar
    Join Date
    Aug 2015
    Location
    Sheffield
    Posts
    431
    Quote Originally Posted by RenboRacer View Post
    Just wanted to let others know of my problem. Wouldn't want it to happen to anybody else
    Nowt wrong with that mate

  11. #11
    One Litre Duc Eater Paul D's Avatar
    Join Date
    Jan 2015
    Location
    Midlands (UK)
    Posts
    541
    Quote Originally Posted by RenboRacer View Post
    Just wanted to let others know of my problem. Wouldn't want it to happen to anybody else
    Rendo,

    Appreciated. What bike do you have, and what mileage did the dud engine have on it?

    How long did you have it before it failed, and many owners in total?

    Just wondering if it had been used and abused before you got it, hence it may have failed anyway.

    The only real way of telling cause is to have engine analysed by a metallurgist, to define what broke and why

  12. #12
    AMA Pit Boss grin factor's Avatar
    Join Date
    Aug 2009
    Location
    Sunderland
    Posts
    4,938
    Quote Originally Posted by Blade View Post
    10/40 wouldn't cause that to happen it would have happened anyway
    Exactly, ran my gen 2 on 10/40 for 4 years without any probs.
    Still a bummer your engine went tho

Similar Discussions

  1. Just registered and thought i would say hello..
    By windaelicker in forum Aprilia RSV Tuono
    Replies: 21
    Last Post: August 18th, 2012, 01:39 AM
  2. Thought I'd pop in and say hello.
    By Robbieben in forum Aprilia RSV Tuono
    Replies: 13
    Last Post: March 14th, 2011, 01:35 PM

Search tags for this page

Click on a term to search for related topics.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


SEO by vBSEO 3.6.1