Results 1 to 2 of 2

Thread: Coolant issue

  1. #1
    Baby Twin Woody's Avatar
    Join Date
    Feb 2009
    Location
    New Zealand
    Posts
    35

    Question Coolant issue

    Hi Guys/Gals

    I have just changed the coolant in my 04 T. The coolant drained out of the bike came to 2.6 litres which according to the manual is about right. I poured the new coolant in and I could not put the same amount in. I still have 400 mls to go and it is full. I am thinking there may be an air bubble somewhere? I have tried running the bike for a while and also riding up and down the street a few times. Still no good. The reserve bottle still shows the same level too. Any tips for a mechanically challenged Tuono Lover?

    Cheers

    Woody.

  2. #2
    One Litre Duc Eater Chunkylad's Avatar
    Join Date
    Jul 2008
    Location
    North Queensland, Oz
    Posts
    721
    There's an air bleed point at the top r/h side of the radiator.

    See:http://www.apriliaforum.com/forums/s...hlight=coolant

    Cheers

Similar Discussions

  1. Starting issue
    By Snaggle in forum Aprilia RSV Tuono
    Replies: 73
    Last Post: September 13th, 2014, 05:02 AM
  2. Gen 2 charging issue again
    By Masfel in forum Aprilia RSV Tuono
    Replies: 8
    Last Post: June 24th, 2012, 02:12 PM
  3. Headlight issue
    By maxmeyer in forum Aprilia RSV Tuono
    Replies: 14
    Last Post: October 5th, 2009, 05:05 AM
  4. Anyone else with this issue??
    By mpgscott in forum Aprilia RSV Tuono
    Replies: 24
    Last Post: August 17th, 2009, 01:24 AM
  5. Dangerous issue with my 04 Tuono
    By Woody in forum Aprilia RSV Tuono
    Replies: 15
    Last Post: April 20th, 2009, 09:03 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


SEO by vBSEO 3.6.1