Results 1 to 7 of 7

Thread: Bubbles in oil level site tube

  1. #1
    Baby Twin nedwood's Avatar
    Join Date
    Aug 2016
    Location
    harlow
    Posts
    7

    Question Bubbles in oil level site tube

    Hi, new to Tuono, i have bubbles in my oil level tube, and it seems a bit low, is this normal? also, what type of oil would you use to top it up?

  2. #2
    One Litre Duc Eater chris13's Avatar
    Join Date
    Nov 2014
    Location
    sheffield, yorkshire
    Posts
    617
    When are you checking the level, needs to be done when engine is warm, due to the dry sump,

    I've just changed mine and used putoline nanotec, 10w - 50 , fully synthetic.

    Can't help with the bubbles, not come across it before,

  3. #3
    Evil Twin hs2300's Avatar
    Join Date
    Aug 2015
    Location
    Sheffield
    Posts
    377
    Quote Originally Posted by nedwood View Post
    Hi, new to Tuono, i have bubbles in my oil level tube, and it seems a bit low, is this normal? also, what type of oil would you use to top it up?
    How many bubbles, what colour, when are they there?

  4. #4
    Baby Twin nedwood's Avatar
    Join Date
    Aug 2016
    Location
    harlow
    Posts
    7
    its like theres a head on the oil level in the tube after a ride, but it goes away after a little while

  5. #5
    One Litre Duc Eater Paul D's Avatar
    Join Date
    Jan 2015
    Location
    Midlands (UK)
    Posts
    541
    In a wet sump system, oil bubbles are usually due to over fill, and crank webs are whipping up the oil. Don't think that can happen in a dry sump system though, as on a Tuono. I've read the oil pump can cause bubbles, even on a dry sump system, especially if engine run at high revs such as when racing.

    Were you riding the engine hard?

    Have you checked the oil level yet, with oil at normal running temperature (not just a hot engine)?

    New/good oil was anti foaming agents. If oil is old these could be breaking down.

  6. #6
    Evil Twin hs2300's Avatar
    Join Date
    Aug 2015
    Location
    Sheffield
    Posts
    377
    Quote Originally Posted by Paul D View Post
    In a wet sump system, oil bubbles are usually due to over fill, and crank webs are whipping up the oil. Don't think that can happen in a dry sump system though, as on a Tuono. I've read the oil pump can cause bubbles, even on a dry sump system, especially if engine run at high revs such as when racing.

    Were you riding the engine hard?

    Have you checked the oil level yet, with oil at normal running temperature (not just a hot engine)?

    New/good oil was anti foaming agents. If oil is old these could be breaking down.

    +1 Paul

    If it happens every ride I would consider an oil and filter change first.

  7. #7
    One Litre Duc Eater
    Join Date
    Mar 2012
    Location
    southampton area
    Posts
    936
    I always do 10mls before an oil level check from cold, or check when garage get it after journey

Similar Discussions

  1. gen 1... 04 throttle tube
    By roy in forum Want to Buy
    Replies: 1
    Last Post: May 20th, 2013, 01:41 PM
  2. U.S. site
    By kneedown in forum Aprilia RSV Tuono
    Replies: 16
    Last Post: January 8th, 2012, 09:41 AM
  3. AP you tube account active!
    By fusebox in forum Aprilia RSV Tuono
    Replies: 4
    Last Post: January 18th, 2011, 08:59 AM
  4. New to the site
    By tuvalox in forum Pictures
    Replies: 11
    Last Post: October 5th, 2008, 11:00 AM
  5. New to site
    By Bushmyster in forum Aprilia RSV Tuono
    Replies: 5
    Last Post: September 4th, 2008, 09:08 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


SEO by vBSEO 3.6.1